Check out example codes for "OSX Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib". It will help you in understanding the concepts better.

Code Example 1

Switch to an older openssl package

brew switch openssl 1.0.2s

Or, depending on your exact system configuration, 
you may need to switch to a different version. 
Check the output of ls -al /usr/local/Cellar/openssl for the version number to switch to.

brew switch openssl 1.0.2q
# or
brew switch openssl 1.0.2r
# or 
brew switch openssl 1.0.2s
# or
brew switch openssl 1.0.2t
# etc...

Learn ReactJs, React Native from akashmittal.com