Check out example codes for "The react-scripts package provided by Create React App requires a dependency: [1] [1] "webpack": "4.42.0"". It will help you in understanding the concepts better.

Code Example 1

SKIP_PREFLIGHT_CHECK=true

Learn ReactJs, React Native from akashmittal.com